FileZilla ist kostenlose Software, hat zwei Versionen: FileZilla-Client und FileZilla-Server. Der Client bietet plattformübergreifende Unterstützung, der Server ist jedoch nur mit Windows kompatibel. Diese Anwendung wird verwendet, um Dateien zwischen Computern in einem Netzwerk zu übertragen. jedoch, In letzter Zeit gab es viele Berichte, dass Benutzer beim Versuch, eine Verbindung zum Server herzustellen, den Fehler »Verzeichnisliste konnte nicht abgerufen werden« erfahren.

Was verursacht den Fehler “Verzeichnisliste konnte nicht abgerufen werden” in FileZilla?
Nach Erhalt zahlreicher Berichte von verschiedenen Benutzern, Wir haben uns entschieden, das Problem zu untersuchen und haben eine Reihe von Lösungen gefunden, die es für die meisten unserer Benutzer beseitigt haben. Was ist mehr, Wir untersuchen die Gründe, warum dieses Problem ausgelöst wird, und listen einige der häufigsten unten auf.
-
Firewall von Windows: In den meisten Fällen, FileZilla-Server funktionierte lokal, aber nicht remote remote. Jedes Mal, wenn lokal ein Verbindungsversuch unternommen wurde, dieser Fehler wurde aktiviert. Dieser Fehler wird ausgelöst, weil die Windows-Firewall die FileZilla-Verbindung blockiert hat. Obwohl die Ausnahme für einen bestimmten Port in der Firewall hinzugefügt werden könnte, verwendet immer noch einen »Passiven Modus« zum Senden und Empfangen von Dateien. Dies geschieht auf zufälligen TCP-Ports. Deshalb, die Firewall blockiert diese Ports und dieser Fehler tritt auf.
-
Verschlüsselung: Es gibt verschiedene Arten der Verbindungsverschlüsselung, die Sie verwenden können, wenn Sie versuchen, eine Verbindung zum Server herzustellen. Obwohl einige sicherer sind als andere, sie können selbst bei legitimen Verbindungen oft Probleme verursachen, indem sie den Verbindungsaufbau verhindern.
Jetzt haben Sie ein grundlegendes Verständnis der Art des Problems, wir suchen nach lösungen. Stellen Sie sicher, dass Sie sie so anwenden, wie sie dargestellt werden, um Konflikte zu vermeiden.
Lösung 1: Erstellen Sie eine Firewall-Regel
Wenn die Firewall FileZilla daran hindert, mit dem Internet zu kommunizieren, funktioniert nicht richtig und der Fehler tritt auf. Deshalb, in diesem Schritt, wir werden zuerst die Ports für FileZilla begrenzen und dann Ausnahmen für sie in der Firewall hinzufügen. Das zu tun:
-
Starten Sie den "FileZilla Server" auf dem Computer "Server".
-
Klicken Sie auf die Option »Bearbeiten« und wählen Sie aus der Liste «Einstellungen» aus.
Klicken auf “Bearbeiten” und auswählen “Rahmen”
-
Klicken Sie im linken Bereich auf die Option »Passive Mode Settings« und aktivieren Sie die Option »Use custom port range«..
-
Geben Sie »2100» in das erste Feld und in das zweite Feld ein.
Bitte eingeben 2100 in beiden Boxen
-
Klicken Sie auf »OK«, um die Einstellungen zu speichern.
-
Drücken Sie die Tasten »Windows» + »I» gleichzeitig, um die Konfiguration zu öffnen.
-
Klicken Sie auf »Update & Sicherheit« und wählen Sie im linken Bereich »Windows-Sicherheit«.
Auswahl “Update und Sicherheit”
-
Klicken Sie auf die Option »Firewall- und Netzwerkschutz« und wählen Sie die Schaltfläche »Erweiterte Einstellungen»..
Klicken auf “Erweiterte Konfiguration”
-
Klicken Sie mit der linken Maustaste auf die Option »Eingehende Regel« und klicken Sie dann erneut mit der rechten Maustaste.
-
Wählen Sie »Neue Regel» aus der Liste.
Wählen Sie «Neue Regel»
-
Unter der Überschrift »Welchen Regeltyp möchten Sie erstellen«, markieren Sie die Option »Port« und klicken Sie auf «Weiter».
Markieren der Option «Port»
-
Aktivieren Sie die Option »TCP« und aktivieren Sie die Option »Spezifische lokale Ports«.
Markieren Sie «TCP» und die Option «Spezifische lokale Ports»
-
Geben Sie »21'2100» in das Feld ein und klicken Sie auf «Weiter».
Hinweis: Anstelle von 21 Geben Sie den Port ein, den Sie beim Erstellen des Servers ausgewählt haben
-
Aktivieren Sie die Option »Verbindung zulassen« und klicken Sie auf »Weiter«.
Klicke auf “Verbindung zulassen”
-
Auf dem nächsten Bildschirm, Aktivieren Sie die Option »Privat«, »Domain« und die Option »Öffentlich«.
Überprüfen der Privatoptionen, Domain und öffentlich
-
Klicken Sie auf »Weiter« und geben Sie den gewünschten Namen für diese Regel ein.
Eingabe des Regelnamens
-
Klicken Sie auf »Fertig stellen«, um diese Regel hinzuzufügen.
-
Wiederholen Sie diesen Vorgang für »Outbound Rules«, um die gleiche Regel auch dafür hinzuzufügen.
-
Wenn diese Regeln hinzugefügt wurden, Überprüfen Sie, ob das Problem weiterhin besteht.
Lösung 2: Codierung ändern
Verschlüsselungseinstellungen können das Problem verursachen. Deshalb, In diesem Schritt ändern wir die Verschlüsselung der Verbindung. Dafür:
-
Öffnen Sie »FileZilla Client» auf dem Computer »Client».
-
Klicke auf “Datei” und wählen Sie “Seitenadministrator”.
Durch Klicken auf Datei und Auswählen von “Seitenadministrator”
-
Wenn der Server, mit dem Sie sich verbinden möchten, noch nicht da ist, wählen Sie »Neue Seite«.
-
Hostnamen hinzufügen host, den Benutzernamen und das Passwort für die Verbindung.
-
Klicken Sie auf das Drop-Down-Menü »Login-Typ« und wählen Sie »Normal«.
-
Klicken Sie auf das Dropdown-Menü »Verschlüsselung« und wählen Sie »Nur einfaches FTP verwenden«.
Verschlüsselungseinstellungen ändern
-
Stellen Sie die Verbindung her und prüfen Sie, ob das Problem weiterhin besteht.
Lösung 3: FTP-Einstellungen ändern
In manchen Fällen, Die FTP-Einstellungen sind möglicherweise aufgrund eines aufgetretenen Fehlers nicht richtig konfiguriert. Deshalb, in diesem Schritt, Wir werden bestimmte FTP-Einstellungen ändern. Dafür:
-
Öffnen Sie »FileZilla Client» in »Client» Computer.
-
Klicken Sie auf »Bearbeiten« und wählen Sie »Einstellungen«.
Klicken auf “Bearbeiten” und auswählen “Rahmen”
-
Klicken Sie unter »Verbindungen« auf »FTP« und aktivieren Sie die Option »Aktiv«.
Auf FTP klicken und prüfen “Aktiv”
-
Kennzeichen “Rollback auf andere Übertragungsmodi bei Fehler zulassen”.
-
Klicken Sie unter der Rubrik «FTP» auf »Aktiver Modus« und aktivieren Sie die Option »Fragen Sie Ihr Betriebssystem nach der externen IP-Adresse«.
Klicken auf “Aktiver Modus” und die Option markieren “Fragen Sie Ihr Betriebssystem nach der externen IP-Adresse”
-
Klicken Sie auf die Option »Passiver Modus« und aktivieren Sie die Option »Zurück in den aktiven Modus«.
Klicken Sie auf «Passiver Modus» und aktivieren Sie die Option «Zurück zum aktiven Modus»
-
Klicken Sie auf »OK«, um die Einstellungen zu speichern und zu prüfen, ob das Problem weiterhin besteht.
Lösung 4: den Hostnamen ändern
Manchmal, beim Herstellen einer Verbindung zu einem bestimmten Host, Das Ändern des Hostnamens, um ein bestimmtes Protokoll zu starten, kann den Fehler beheben. Deshalb, in diesem Schritt, Wir werden den Hostnamen ändern. Dafür:
-
Öffnen Sie »FileZilla Client» auf dem Computer »Client».
-
Klicken Sie auf die Option »Hostname«.
-
Geben Sie Folgendes vor dem tatsächlichen Namen des Servers ein
sftp://
Hinzufügen “sftp: //” vor dem Servernamen
-
Geben Sie die restlichen Details ein und prüfen Sie, ob das Problem weiterhin besteht.
Verwandter Beitrag:
- ▷ So platzieren Sie Google Kalender auf dem Desktop in Windows 10?
- ▷ So beheben Sie “Kein Zugriff auf Windows Smartscreen möglich
- ▷ So entfernen Sie / Hyperlink in Word auf dem Mac hinzufügen
- So beheben Sie, dass der Ordner in Windows immer wieder schreibgeschützt ist 10
- ⭐ Disney Plus und Firestick: So installieren und ansehen
- Kein Kontakt zu Ihrem DHCP-Server Fehler in Windows 7, 8, 10
Klicken auf “Bearbeiten” und auswählen “Rahmen”
Bitte eingeben 2100 in beiden Boxen
Auswahl “Update und Sicherheit”
Klicken auf “Erweiterte Konfiguration”
Wählen Sie «Neue Regel»
Markieren der Option «Port»
Markieren Sie «TCP» und die Option «Spezifische lokale Ports»
Klicke auf “Verbindung zulassen”
Überprüfen der Privatoptionen, Domain und öffentlich
Eingabe des Regelnamens
Durch Klicken auf Datei und Auswählen von “Seitenadministrator”
Verschlüsselungseinstellungen ändern
Klicken auf “Bearbeiten” und auswählen “Rahmen”
Auf FTP klicken und prüfen “Aktiv”
Klicken auf “Aktiver Modus” und die Option markieren “Fragen Sie Ihr Betriebssystem nach der externen IP-Adresse”
Klicken Sie auf «Passiver Modus» und aktivieren Sie die Option «Zurück zum aktiven Modus»
Hinzufügen “sftp: //” vor dem Servernamen



