So beheben Sie den Fehler $ 0027 Verzeichnisliste konnte nicht abgerufen werden $ 0027 in FileZilla

Inhalt

FileZilla ist kostenlose Software, hat zwei Versionen: FileZilla-Client und FileZilla-Server. Der Client bietet plattformübergreifende Unterstützung, der Server ist jedoch nur mit Windows kompatibel. Diese Anwendung wird verwendet, um Dateien zwischen Computern in einem Netzwerk zu übertragen. jedoch, In letzter Zeit gab es viele Berichte, dass Benutzer beim Versuch, eine Verbindung zum Server herzustellen, den Fehler »Verzeichnisliste konnte nicht abgerufen werden« erfahren.

failed_to_retrieve_directory_listing-4780113Verzeichnislistenfehler in FileZilla konnte nicht abgerufen werden retrieve

Was verursacht den Fehler “Verzeichnisliste konnte nicht abgerufen werden” in FileZilla?

Nach Erhalt zahlreicher Berichte von verschiedenen Benutzern, Wir haben uns entschieden, das Problem zu untersuchen und haben eine Reihe von Lösungen gefunden, die es für die meisten unserer Benutzer beseitigt haben. Was ist mehr, Wir untersuchen die Gründe, warum dieses Problem ausgelöst wird, und listen einige der häufigsten unten auf.

  • Firewall von Windows: In den meisten Fällen, FileZilla-Server funktionierte lokal, aber nicht remote remote. Jedes Mal, wenn lokal ein Verbindungsversuch unternommen wurde, dieser Fehler wurde aktiviert. Dieser Fehler wird ausgelöst, weil die Windows-Firewall die FileZilla-Verbindung blockiert hat. Obwohl die Ausnahme für einen bestimmten Port in der Firewall hinzugefügt werden könnte, verwendet immer noch einen »Passiven Modus« zum Senden und Empfangen von Dateien. Dies geschieht auf zufälligen TCP-Ports. Deshalb, die Firewall blockiert diese Ports und dieser Fehler tritt auf.

  • Verschlüsselung: Es gibt verschiedene Arten der Verbindungsverschlüsselung, die Sie verwenden können, wenn Sie versuchen, eine Verbindung zum Server herzustellen. Obwohl einige sicherer sind als andere, sie können selbst bei legitimen Verbindungen oft Probleme verursachen, indem sie den Verbindungsaufbau verhindern.

Jetzt haben Sie ein grundlegendes Verständnis der Art des Problems, wir suchen nach lösungen. Stellen Sie sicher, dass Sie sie so anwenden, wie sie dargestellt werden, um Konflikte zu vermeiden.

Lösung 1: Erstellen Sie eine Firewall-Regel

Wenn die Firewall FileZilla daran hindert, mit dem Internet zu kommunizieren, funktioniert nicht richtig und der Fehler tritt auf. Deshalb, in diesem Schritt, wir werden zuerst die Ports für FileZilla begrenzen und dann Ausnahmen für sie in der Firewall hinzufügen. Das zu tun:

  1. Starten Sie den "FileZilla Server" auf dem Computer "Server".

  2. Klicken Sie auf die Option »Bearbeiten« und wählen Sie aus der Liste «Einstellungen» aus. 2019-06-19_164559-3447176Klicken auf “Bearbeiten” und auswählen “Rahmen”

  3. Klicken Sie im linken Bereich auf die Option »Passive Mode Settings« und aktivieren Sie die Option »Use custom port range«..

  4. Geben Sie »2100» in das erste Feld und in das zweite Feld ein. 2019-06-19_164649-3830776Bitte eingeben 2100 in beiden Boxen

  5. Klicken Sie auf »OK«, um die Einstellungen zu speichern.

  6. Drücken Sie die Tasten »Windows» + »I» gleichzeitig, um die Konfiguration zu öffnen.

  7. Klicken Sie auf »Update & Sicherheit« und wählen Sie im linken Bereich »Windows-Sicherheit«. 2019-06-19_162521-1119129Auswahl “Update und Sicherheit”

  8. Klicken Sie auf die Option »Firewall- und Netzwerkschutz« und wählen Sie die Schaltfläche »Erweiterte Einstellungen».. 2019-06-19_162613-6581274Klicken auf “Erweiterte Konfiguration”

  9. Klicken Sie mit der linken Maustaste auf die Option »Eingehende Regel« und klicken Sie dann erneut mit der rechten Maustaste.

  10. Wählen Sie »Neue Regel» aus der Liste. 2019-06-19_162335-8678312Wählen Sie «Neue Regel»

  11. Unter der Überschrift »Welchen Regeltyp möchten Sie erstellen«, markieren Sie die Option »Port« und klicken Sie auf «Weiter». 2019-06-19_162353-1640405Markieren der Option «Port»

  12. Aktivieren Sie die Option »TCP« und aktivieren Sie die Option »Spezifische lokale Ports«. 2019-06-19_162418-1089249Markieren Sie «TCP» und die Option «Spezifische lokale Ports»

  13. Geben Sie »21'2100» in das Feld ein und klicken Sie auf «Weiter».

    Hinweis: Anstelle von 21 Geben Sie den Port ein, den Sie beim Erstellen des Servers ausgewählt haben

  14. Aktivieren Sie die Option »Verbindung zulassen« und klicken Sie auf »Weiter«. 2019-06-19_162427-2172784Klicke auf “Verbindung zulassen”

  15. Auf dem nächsten Bildschirm, Aktivieren Sie die Option »Privat«, »Domain« und die Option »Öffentlich«. 2019-06-19_162443-3272850Überprüfen der Privatoptionen, Domain und öffentlich

  16. Klicken Sie auf »Weiter« und geben Sie den gewünschten Namen für diese Regel ein. 2019-06-19_162456-6168191Eingabe des Regelnamens

  17. Klicken Sie auf »Fertig stellen«, um diese Regel hinzuzufügen.

  18. Wiederholen Sie diesen Vorgang für »Outbound Rules«, um die gleiche Regel auch dafür hinzuzufügen.

  19. Wenn diese Regeln hinzugefügt wurden, Überprüfen Sie, ob das Problem weiterhin besteht.

Lösung 2: Codierung ändern

Verschlüsselungseinstellungen können das Problem verursachen. Deshalb, In diesem Schritt ändern wir die Verschlüsselung der Verbindung. Dafür:

  1. Öffnen Sie »FileZilla Client» auf dem Computer »Client».

  2. Klicke auf “Datei” und wählen Sie “Seitenadministrator”. 2019-06-19_164744-2434379Durch Klicken auf Datei und Auswählen von “Seitenadministrator”

  3. Wenn der Server, mit dem Sie sich verbinden möchten, noch nicht da ist, wählen Sie »Neue Seite«.

  4. Hostnamen hinzufügen host, den Benutzernamen und das Passwort für die Verbindung.

  5. Klicken Sie auf das Drop-Down-Menü »Login-Typ« und wählen Sie »Normal«.

  6. Klicken Sie auf das Dropdown-Menü »Verschlüsselung« und wählen Sie »Nur einfaches FTP verwenden«. 2019-06-19_164824-8784142Verschlüsselungseinstellungen ändern

  7. Stellen Sie die Verbindung her und prüfen Sie, ob das Problem weiterhin besteht.

Lösung 3: FTP-Einstellungen ändern

In manchen Fällen, Die FTP-Einstellungen sind möglicherweise aufgrund eines aufgetretenen Fehlers nicht richtig konfiguriert. Deshalb, in diesem Schritt, Wir werden bestimmte FTP-Einstellungen ändern. Dafür:

  1. Öffnen Sie »FileZilla Client» in »Client» Computer.

  2. Klicken Sie auf »Bearbeiten« und wählen Sie »Einstellungen«. 2019-06-19_165028-4977523Klicken auf “Bearbeiten” und auswählen “Rahmen”

  3. Klicken Sie unter »Verbindungen« auf »FTP« und aktivieren Sie die Option »Aktiv«. 2019-06-19_165129-6198931Auf FTP klicken und prüfen “Aktiv”

  4. Kennzeichen “Rollback auf andere Übertragungsmodi bei Fehler zulassen”.

  5. Klicken Sie unter der Rubrik «FTP» auf »Aktiver Modus« und aktivieren Sie die Option »Fragen Sie Ihr Betriebssystem nach der externen IP-Adresse«. 2019-06-19_165237-3707386Klicken auf “Aktiver Modus” und die Option markieren “Fragen Sie Ihr Betriebssystem nach der externen IP-Adresse”

  6. Klicken Sie auf die Option »Passiver Modus« und aktivieren Sie die Option »Zurück in den aktiven Modus«. 2019-06-19_165340-4261802Klicken Sie auf «Passiver Modus» und aktivieren Sie die Option «Zurück zum aktiven Modus»

  7. Klicken Sie auf »OK«, um die Einstellungen zu speichern und zu prüfen, ob das Problem weiterhin besteht.

Lösung 4: den Hostnamen ändern

Manchmal, beim Herstellen einer Verbindung zu einem bestimmten Host, Das Ändern des Hostnamens, um ein bestimmtes Protokoll zu starten, kann den Fehler beheben. Deshalb, in diesem Schritt, Wir werden den Hostnamen ändern. Dafür:

  1. Öffnen Sie »FileZilla Client» auf dem Computer »Client».

  2. Klicken Sie auf die Option »Hostname«.

  3. Geben Sie Folgendes vor dem tatsächlichen Namen des Servers ein

    sftp://

    2019-06-19_165455-8547706Hinzufügen “sftp: //” vor dem Servernamen

  4. Geben Sie die restlichen Details ein und prüfen Sie, ob das Problem weiterhin besteht.

Abonnieren Sie unseren Newsletter

Wir senden Ihnen keine SPAM-Mail. Wir hassen es genauso wie du.